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1- Installing SBMLeditor

You will find useful information about SBMLeditor installation on the page : 
http://www.ebi.ac.uk/compneur-srv/SBMLeditor.html

Here are the information provided on this page :
In order to run properly SBMLeditor you will need first to install the Java JRE 
you can download from the Java web site : 
http://java.sun.com/javase/downloads/index.jsp

After downloading and installing properly the Java JRE, you can download the 
installer on the address cited previously. 

SBMLeditor has been successfully tested on Linux, Mac OS X and Windows 
machine.

http://www.ebi.ac.uk/compneur-srv/SBMLeditor.html
http://java.sun.com/j2se/1.4.2/download.html


2 – Navigate through SBMLeditor

SBMLeditor has an really intuitive interface.

Everything can be done by doing right click on the various elements.

We strongly advise users to first  try by navigate through the different sub 
menus  displayed by  right  clicking  on the  various  elements  created on the 
SBMLeditor window and through the tree structure of the SBML file displayed 
into the main window.

There is also a lot of shortcuts you may want to use.

You can type these shortcuts anywhere in the tree, you will automatically be 
moved to the right place. If no listOf is present for the element you want to 
add, it will be added automatically at the same time as your element.

Here is a list of shortcuts to use in the tree :
Ctrl-I : add a FunctionDefinition
Ctrl-C : add a Compartment
Ctrl-S : add a Species
Ctrl-P : add a Parameter
Ctrl-T : add a RateRule
Ctrl-M : add an AssignmentRule
Ctrl-G : add an AlgebraicRule
Ctrl-R : add a Reaction
Ctrl-E : add an Event

Depending on the context you will be able to use those shorcuts :

ctrl-U : add a UnitDefinition or Unit
Ctrl-B : add a Product (in a listOfReaction field)
Ctrl-A : add a Reactant (in a listOfReaction field)
Ctrl-D : add a Modifier (in a listOfReaction field)
Ctrl-L : add a local parameter (in a listOfReaction field)
Ctrl-H : add an EventAssignement (in a listOfEvents field)
Ctrl-K : add a KineticLaw (in a listOfReaction field) ?

In the main tree you will also be able to use those shortcuts :

E      : edit the selected element
D      : delete the selected element

Ctrl-N : create a new SBML file
Ctrl-O : open a SBML file
Ctrl-V : validate the current model
Ctrl-F : find/search for a name or id
Ctrl-W : save the current model to a file



Ctrl-Q : close the window, if it's the last window, close the application
Ctrl-+ : expand all nodes from selected
Ctrl-- : collapse all nodes from selected

3 – How to create an SBML file

Using SBMLeditor must be really intuive and users will be using a lot the right 
click of their mouse (for mac user, the right click can be done by pressing the 
Ctrl and then click with their mouse).

A – First : Create a new SBML file or import a SBML file 

In order to create a new SBML file, users will have the choose between click 
on the button New on the left side of the button bar or to click on File menu 
then New.

The id and the name are automatically generated for the model, but you will 
be able to change the name but not the id.

A structure of an SBML file  will  be generated. By default,  the file  will  be 
SBML level 2, version 1, therefore, it is possible to change this to version 1, 
level 2 by clicking on the File menu and then by choosing the version of the 
SBML file you want to create.

If you want to import an SBML file, user can click either on the File menu 
then Open... or they can click on the open file button on the button bar and 
then choose the file they want to import.

B – Save and validate an SBML file

Each time you will want to save an SBML file, SBMLeditor will automatically 
check if the SBML file is compliant with the SBML specifications.

You can also directly  check the  the validity  of  your  SBML file  by clicking 
either  on the blue and red button (see fig)  or  on the File  menu and then 
choosing validate.

C – Adding parts to the SBML file

When a file is created you can, by doing a right click on model, choose every 
part you want to create in your SBML file. See Figure 1 for details :



Every time you will want to add an element you will have to create first the 
listOf corresponding to the part you want to create and then to right click on 
the listOf and choose “Add New “. See Figure 2 for example :

For everything you will  create you will  be asked to give an id and all  the 
information required for the type of SBML element you have added. The id 

Figure 1: Mouse Menu on the model element

Figure 2: Example of a ListOf Menu



must  be  chosen  carefully  because  it  will  not  be  possible  to  change  it 
afterwards with SBMLeditor,  you may be able to change it  directly  in the 
SBML file with an text editor but users must be aware that it could create 
problem of id conflict in the model. In addition, the id must begin with a letter 
or  an  underscore  and  can't  have  symbol  others  that  letter,  number  or 
underscore.

If in SBMLeditor you are not giving all the information required or if you are 
doing a mistake, SBMLeditor will tell you what is the mistake and eventually 
how to correct it (see figure 3).

For further information about the SBML specifications we strongly 
recommend to look to the SBML website :  http://www.sbml.org/ and search in 
the documentation section for the latest specifications.

D – Details for each Element

1) Creation of Annotations, Notes, Contributors, Creators

SBMLeditor provides a way to add useful informations to the SBML file for 
further use of the file by other people not used to the model described by the 
file.

So, by right clicking on “sbml” in the main window and then clicking on Add... 

Figure 3 – SBMLeditor detects the error 
and provides an help in order to correct it

http://sbml.org/index.psp


you can choose to add Contributors, Notes, Annotations (see fig 4).

Contributor fields are : Family Name, Given Name, email, and Organization 
name.

For Notes and Annotations, a new window is provided with the tags which will 
be inserted into the XML. Therefore, the user need to write between those 
tags in order to avoid to have an error message because SBMLeditor check 
the integrity of the SBML file and does not authorize error in it 

By right clicking on “model“ in addition of those previously cited, the user will 
be able to add a Creator field which has the same fields as Contributor.

Then, for every field, the user will be able to create annotations or notes.

2) Creation of a relation field

By right clicking on model, as previously explained, the user will be able to 
create every fields allowed by SBML lib.

So, it is possible to create an Relation field (see fig 5) where the user is able to 
define the Qualifier (see http://sbml.org/wiki/Biomodels_Qualifiers for details) 
and the URIs (see http://sbml.org/wiki/MIRIAM_URI_Set for details). When the 
user clicks on one URIs among the selection, SBMLeditor automatically fill in 
the URI field and the user therefore has to enter a proper ID compliant with 
the URI.  For example,  if  the user clicks on Gene Ontology,  the ID will  be 
automatically filled by the tern “GO:” and if you put your mouse on the ID 
field, an contextual help will be provided to help user to enter the correct form 
of the ID (see fig 6).

3) Creation of an Function Definition

The first thing to do is to create an listOfFunctionDefinitions by right clicking 
on “model”.  After it  is created, right click on listOfFunctionDefinitions and 
choose “Add New functionDefinition”, a new window will  be displayed (see 
figure 7), where you will be able to rename the id, give a name (if you want) 
and edit the MathML. If you've written your MathML formula directly between 
the tags you can choose to untick the “Open mathML editor”.

a) MathML editor

If you have problem with the MathML syntax, you can avoid to write anything 
into the mathML field, let the “Open mathML editor” ticked and click on Ok. 
You will be then invited to write directly the formula into the mathML editor 
(see figure 8).  

In  this  window  you  can  write  directly  using  infix  notation  which  is  more 
natural, the MathML editor will translate the formula in a MathML format. 

In addition, MathML editor window displays a lot of options. As in any other 
editor, you can cut, paste, undo, redo (all available from the button bar or the 
Edit menu). You can also Save in order to write the MathML formula into your 

http://sbml.org/wiki/MIRIAM_URI_Set
http://sbml.org/wiki/Biomodels_Qualifiers


SBML file (you can do it either by clicking on the floppy disk in the button bar 
or in the File menu). After you saved you will have to Exit in order to get back 
to the main SBMLeditor  window.

In the File menu you also can Export in image format (png, jpg), text format 
(txt) or in Windows Meta format (wmf) and choose where you want to save the 
file.
It  is  possible  to  export  under  mathML  format  (mml)  by  choosing  either 
Presentation Markup or Content Markup. 

If you want to use power in your formula or fraction you will have either to 
write the formula in its mathematical form (e.g : 2/3) or you may choose the 
Layout button under the button bar (or in the Insert menu), you will therefore 
choose what to put in power or which part to divide by another part.
If you have problem with having a clear view of the different levels you can 
choose in the View menu to Highlights the Levels.
As you cannot write your formula in more than one line you may experience 
problem with having a general view of your entire formula, especially if it is a 
long one. In the View menu you will be able to Zoom Out or Zoom in. If you 
choose Zoom normal, the view will go back to the default one.

In the Help menu you can have a look to all the shortcuts you can use into the 
Equation editor by clicking on Readme (see fig 9). 

4) Creation of a list of unit definitions

To create a list of unit definition you need to right click on “model” and then 
choose Add... and finally listOfUnitDefinitions (see fig10 ?)

A new field listOfUnitDefinitions will appear, you then have to right click on 
this  field  and  click  on  Add  New  UnitDefinition.  A  new  window  will  be 
displayed  and  you  will  be  able  to  change  the  id  which  is  automatically 
generated  and  give  a  name (this  is  optional).  Pay  attention  to  the  id  you 
choose because once you've clicked on Ok, you won't be allowed to change the 
id.

When your list of units is created you have to click right on the field “list of 
Units” and then choose “Add New unit”. In the new window, you will have to 
choose what is the unit kind between the 33 values possible. It is the only field 
you have to fill (if you don't, SBMLeditor will display an error and ask you to 
choose a unit kind). You can after this choose what to enter in the different 
optional fields (Exponent, Scale, Multiplier).

5) Creation of a list of Compartments

To create a list of unit definition you need to right click on “model” and then 
choose Add... and finally listOfCompartments (see fig11 ?).

A new field ListOfCompartments will appear, you then have to right click on 
this field and click on Add New Compartment.



In  the  new  window,  there  is  no  required  field  except  the  id  which  is 
automatically  pre-filled.  You  can  choose  to  modify  everything  you  need 
between the fields  id, name, size, spatialDimensions, unit, outside, constant 
(see fig 12).

From the new compartment you create you can add a relation as described on 
part C, 1. But you will not be able to choose the URI which is Gene ontology.

Please notice that the list of URIs are following the definitions of the SBML 
site (http://www.biomodels.net/miriam/). If you want to add your own URI, you 
can use the “Submit New” form on the web site.

6) Creation of a list of Species

To create a list of Species you need to right click on “model” and then choose 
Add... and finally listOfSpecies (see fig12 ?).

A new field ListOfSpecies will appear, you then have to right click on this field 
and click on Add New species.

In  the  new  window  (see  fig  13),  you  can  choose  the  id,  the  name, 
Compartment (beware that if you didn't previously create an compartment you 
will not be allowed to create species), initial Amount, initial Concentrations, 
substanceUnits,  spatialSizeUnits,  OnlySubstanceUnits,  Boundary Conditions, 
charge, constant (by default the charge is positive, you will have to specify the 
negative charge, e.g : -2).

According  to  SBML  specifications,  the  fields  hasOnlySubstanceUnits, 
boundaryCondition, constant, have default value “false”. It is not specified into 
the window and you can either “confirm” the value false or change the value 
to “true”.

7) Creation of a list of Parameters

To create a list of Parameters you need to right click on “model” and then 
choose Add... and finally listOfParameters (see fig14 ?).

A new field ListOfParameters will appear, you then have to right click on this 
field and click on Add New parameter.

In  the  new window,  you will  be  able  to  choose  the  id,  name,  value,  unit, 
constant. Except for the id which is automatically generated and that you have 
to specify, none of the fields are required. Please pay attention to the fact that 
the constant field has two choices true and false and by default, as defined on 
the SBML specifications, the value is true.

SBML allows two kind of  parameters,  the  one you create  from the list  of 
Parameters will be global.

http://sbml.org/wiki/MIRIAM_URI_Set


But you will be also allowed to create a local parameter which will be assigned 
to a specific reaction (this can be done form the MathML editor, for ruther 
explanation please see the section 9 – a) MathML editor).

8) Creation of a list of Rules

To create a list of Rules you need to right click on “model” and then choose 
Add... and finally listOfRules (see fig15 ?).

A new field ListOfRules will appear, you then have to right click on this field 
and by selection “Add new...”  you will  have to choose between 3 different 
rules (see fig 16).

a) Algebraic Rules

A new window will be displayed in which you will be able to enter the formula 
directly in MathML format or you can choose to open the MathML editor by 
clicking on OK without deticking the field “Open mathML editor”. Behaviour 
of MathML editor will be described in the d) part of this section.

b) Assignment rules

In  this  window where you will  be  invited  to  enter  the  formula  directly  in 
mathML format, you will also have the possibility to choose your Tag type and 
you will have to choose the variable, otherwise SBMLeditor will not allow you 
to continue.

Then if you want to use the MathML editor, click on OK without deticking the 
Open MathML editor field. Behaviour of MathML editor will be described in 
the d) part of this section.

c) Rate Rule

In  this  window where you will  be  invited  to  enter  the  formula  directly  in 
mathML format, you will also have the possibility to choose your Tag type and 
you will have to choose the variable, otherwise SBMLeditor will not allow you 
to continue.

Then if you want to use the MathML editor, click on OK without deticking the 
Open MathML editor field. Behaviour of MathML editor will be described in 
the d) part of this section.

d) MathML editor

In this window you can write either directly in mathML or in a mathematical 
way, the MathML editor will translate the formula in a MathML format. But 
you also can use the both ways in the same formula.

In addition, MathML editor window displays a lot of options. As in any other 
editor, you can cut, paste, undo, redo (all available from the button bar or the 



Edit menu). You can also Save in order to write the MathML formula into your 
SBML file (you can do it either by clicking on the floppy disk in the button bar 
or in the File menu). After you saved you will have to Exit in order to get back 
to the main SBMLeditor  window.

In the File menu you also can Export in image format (png, jpg), text format 
(txt) or in Windows Meta format (wmf) and choose where you want to save the 
file.
It  is  possible  to  export  under  mathML  format  (mml)  by  choosing  either 
Presentation Markup or Content Markup. 

If you want to use power in your formula or fraction you will have either to 
write the formula in its mathematical form (e.g : 2/3) or you may choose the 
Layout button under the button bar (or in the Insert menu), you will therefore 
choose what to put in power or which part to divide by another part.

If you have problem with having a clear view of the different levels you can 
choose in the View menu to Highlights the Levels.
As you cannot write your formula in more than one line you may experience 
problem with having a general view of your entire formula, especially if it is a 
long one. In the View menu you will be able to Zoom Out or Zoom in. If you 
choose Zoom normal, the view will go back to the default one.

In the Help menu you can have a look to all the shortcuts you can use into the 
Equation editor by clicking on Readme (see fig 9). 

At the bottom at the window you have three different menus.

Starting from the left, the first menu allows you to choose if you want to add 
into you rule a functionDefinition, a compartement, a specie, a parameter.

Once you have chosen the category you want, the middle menu will display all 
the elements contained into your category.

If you realized that you forgot to create an element you can still click on the 
right button named “Add New...” and choose to create a new compartment, 
species or parameter. 

A window corresponding to the element you want to create is displayed and 
you can create it.

For further informations about those elements you can create, please refer to 
the corresponding parts.

9) Creation of a listOfReactions

To create a list  of  Reactions you need to right  click  on “model” and then 
choose Add... and finally listOfReactions (see fig17 ?).

A new field ListOfReactions will appear , you then have to right click on this 
field and by selection “Add new...”.



In the window displayed you will be able to change the id, the name and the 
reversible and fast fields. Please note that the default value of the optionnal 
field Reversible is true, according to SBML specifications.

Once you have filled all the field you want, you will be able to choose if you 
want to create the kinetic law or not.

If you don't want to create the kinetic law you will have to detick the “Open 
mathML editor” field. 

If you want to right the kinetic law with the help of the mathML editor, just 
click on OK.

a) MathML editor

In this window you can write either directly in mathML or in a mathematical 
way, the MathML editor will translate the formula in a MathML format. But 
you also can use the both ways in the same formula.

In addition, MathML editor window displays a lot of options. As in any other 
editor, you can cut, paste, undo, redo (all available from the button bar or the 
Edit menu). You can also Save in order to write the MathML formula into your 
SBML file (you can do it either by clicking on the floppy disk in the button bar 
or in the File menu). After you saved you will have to Exit in order to get back 
to the main SBMLeditor  window.

In the File menu you also can Export in image format (png, jpg), text format 
(txt) or in Windows Meta format (wmf) and choose where you want to save the 
file.
It  is  possible  to  export  under  mathML  format  (mml)  by  choosing  either 
Presentation Markup or Content Markup. 

If you want to use power in your formula or fraction you will have either to 
write the formula in its mathematical form (e.g : 2/3) or you may choose the 
Layout button under the button bar (or in the Insert menu), you will therefore 
choose what to put in power or which part to divide by another part.

If you have problem with having a clear view of the different levels you can 
choose in the View menu to Highlights the Levels.
As you cannot write your formula in more than one line you may experience 
problem with having a general view of your entire formula, especially if it is a 
long one. In the View menu you will be able to Zoom Out or Zoom in. If you 
choose Zoom normal, the view will go back to the default one.

In the Help menu you can have a look to all the shortcuts you can use into the 
Equation editor by clicking on Readme (see fig 9). 

At the bottom at the window you have three different menus.



Starting from the left, the first menu allows you to choose if you want to add 
into you rule a functionDefinition, a compartement, a specie, a parameter, a 
local parameter.

Once you have chosen the category you want, the middle menu will display all 
the elements contained into your category.

If you realized that you forgot to create an element you can still click on the 
right button named “Add New...” and choose to create a new compartment, 
species or parameter. 

A window corresponding to the element you want to create is displayed and 
you can create it.

For further informations about those elements you can create, please refer to 
the corresponding parts.

b) Additional parts to the reaction

Once  you've  created and defined the  kinetic  law.  You may have to  create 
Reactants, Products or Modifiers.

This  can  be  done  by  right  clicking  on  reaction  then  choosing  either 
listOfReactants, listOfProducts or listOfProducts.

You will have then to right click of the list you've created and choose “Add a 
new speciesReference”. A new window will appear 

In this window you will have to choose the specie you want to add with the 
species menu (on top). Then you will be able to choose the stoichiometry.

You  can  directly  write  in  the  huge  StoichiometryMath  white  space  the 
mathML equation.

If you want to have the help of the MathML editor don't forget to tick the 
Open MathML editor box on bottom left.

For further explanations about the MathML editor please refer to the previous 
section.

10) Creation of a list of Events

To create a list of Events you need to right click on “model” and then choose 
Add... and finally listOfEvents (see fig17 ?).

A new field ListOfEvents will appear , you then have to right click on this field 
and by selection “Add new Event”.

In  the  window  displayed  you  will  be  able  to  change  the  id,  name  and 
timeUnits.



Once you've written what you want and clicked on OK  a new window named 
“Define  a trigger”  will  appear.  It's  basically  a  mathML editor  window (for 
more  explanations  about  this  editor  peasse  see  the  section  9-a)  MathML 
editor).
Once you've written you trigger, validate it by clicking on OK.

In the trigger sub-tree you will have a creation of a List of Event Assignments.

By right clicking on List of Event Assignments and then choosing “Add New 
eventAssignement” you will make appearing a new window.

In this window, you will be asked to choose the Tag types and variable from 
the two top menu.
Then in the great blank  MathML screen you will be able to write directly the 
formula you want in a mathML format or you can click on OK and let ticked 
the Open mathML editor box.

By doing this you will have the possibility to write directly the formula into the 
Equation editor window.
More explanations about this window in the 9 – a section.
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